[تم الترقيع] ثغرة حديثة 2016 للتيم سبيك[محدث 26/4/2016]

السلام عليكم ورحمة الله وبركاته

تم اكتشاف ثغرة حديثة بتاريخ اليوم وتم انزال ترقيع لها

الثغرة تمكن الشخص المستخدم لها بفصل اتصالك فقط – ولاشي آخر – عن السيرفر ويحدث كراش بعد ذلك في برنامج التيم سبيك

تحديث 1

تم اصدار اصلاحي للثغرة وحمل رقم 3.0.19.1 وتم ترقيع الثغرة ولن تحتاج الى اي بلوقن للحماية من هذه الثغرة

رابط تحميل نسخة برنامج التيم سبيك للاصدار 3.0.19.1 نسخة x64

رابط تحميل نسخة برنامج التيم سبيك للاصدار 3.0.19.1 نسخة x32

 

لذا تم بحمد الله التوصل لحل هذه المشكلة مؤقتا حتى يصدر تحديث جديد من مطوري منصة التيم سبيك

طريقة تثبيت الترقيع بسيطة جدا

1- نقوم بتحميل البلوقن الخاص بحل هذه المشكلة

التحميل من هنا PreventCrash.ksaserver.com

بعد تحميل الملف نقوم بفك الضغط عن الملفات في أي مجلد بعد ذلك نضغط على الملف الخاص بالإضافة

والمسمى preventCrash.ksaserver.ts3_plugin

الخطوة الثالثة

2- بعد تشغيل الإضافة تظهر لنا هذه النافذة كما هو موضح بالصورة نقوم بتثبيتها

بعد تثبيت البلوقن

3 – من القائمة الرئيسية للسيرفر نضغط على settings بعد ذلك Plugins

الخطوة الاولى

بعد ذلك تظهر لنا قائمة البلوقنات الأساسية للسيرفر

نختار Lua Plugin  ونعمل مثل الموجود في الصورة (تفعيل البلوقن )

الخطوة الثانية

بعد ذلك نقوم باغلاق التيم سبيك بشكل كامل

من الواجهة الرئيسية للبرنامج  Connection  بعد ذلك Quit او بالضغط على CTRL + Q  للخروج السريع

ومن ثم تشغيل برنامج التيم سبيك ومبروك حل المشكلة

علما بأن المشكلة موجودة بشكل عام وليست خاصة بسيرفر مجتمع السيرفرات السعودية

آسف على الإطالة

شكر خاص لصاحب الحل Energeek/Boumz